de en es fr
Let the machine help
Light teasing, exhibition, BDSM, sissyfication, watersports... with sounds and pictures


Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Java error in several teases
PostPosted: Fri Feb 15, 2019 8:23 pm 
Offline
Regular
Hi,
I get with Java8 on a Windows System and also Java 10 on Linux operating system error messages in several scripts:

For example Domme3 with chastity script (Domme3_1543065162.zip) starts, but for example when selecting "Ask"
the error message
"No signature of method: java.util.Date.format() is applicable for argument types: (String) values: [dd, MMM, yyyy]
Possible solutions: getAt(java.lang.String), parse(java.lang.String), ...."
is shown even after an downgrade to Java 7 on Windows.

The Script Keyholderroulette aborts immediately with the mesage
"No signature of method: java.util.Date.Format() is applicable for argument types: ...... Zoneinfo. ...." with very lengthy message.

What can I do?

Martin


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Sat Feb 16, 2019 4:21 pm 
Offline
Regular
I attached the errors.log in the hope that somebody can help me with the Java errors.

I also tried the script DisciplineClinic from iSpank, Version 4.0.2 and get an immediate Java error regarding the Date class.


Attachments:
File comment: Logfile with Java errors
errors.log [24.17 KiB]
Downloaded 10 times
Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Sat Feb 16, 2019 4:25 pm 
Offline
Regular
As the website states "You will need Java (6 or more) installed " I thought that I might have a too new version of Java installed and the java.util.Date might have been obfuscated, so I installed JRE of Java 6 but gof a mismatch of minor and major version that would be required to launch the jar file. What is exactly the minimal required Java version?

I should add that sexscripts.exe always gave the error message that no Java version is installed even as it is using Windows 10 and original Java from Oracle website. Hence I made myseld a small sexscripts.bat for starting it.

Could a German locale be part of the problem?


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Sun Feb 17, 2019 12:44 am 
Offline
Active member
I'm running Java 8 (Windows 10) with the previous release of Sexscripts (June 18, 2018) and do not get the date error that others are seeing in any of the referenced scripts.

Is this potentially a problem with the Feb release of Sexscripts or are we breaking a rule by using Java.util.date?


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Sun Feb 17, 2019 9:03 am 
Offline
Regular
Thank you for the information. I would like to test if it also works for me with the previous version. But where can I find this version?


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Wed Feb 20, 2019 6:44 pm 
Offline
Site Admin
User avatar
The version change of Groovy (-> 2.5.5) is the culprit
It seems there are 2 errors:
  • Java 7 is now needed ; well Java 7 was released in 2011 and Java 6 has no more extended support, so this will be definitive
  • The scripts are no more using the groovy special java.util.Date class, but the Java one. I don't know why and I am still searching


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Fri Mar 01, 2019 7:44 pm 
Offline
Shy
Any news on this issue?


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Fri Mar 01, 2019 10:11 pm 
Offline
Site Admin
User avatar
No, identified but no solution for now


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Tue Mar 05, 2019 12:18 am 
Offline
Regular
It's looking like my workaround is working:

I downloaded the Groovy 2.4.16 SDK Bundle (https://dl.bintray.com/groovy/maven/apa ... 2.4.16.zip) and copied the "lib\groovy-2.4.16.jar" and "lib\groovy-json-2.4.16.jar" files into the "sexscript/lib" folder. and renamed them to "______-2.5.5.jar", replacing the original jar files.

It's a really dirty workaround and it will propably cause some new issues.


Top
 Profile Send private message 
 
 Re: Java error in several teases
PostPosted: Wed Mar 06, 2019 2:58 pm 
Offline
Site Admin
User avatar
Fix in today's desktop release. There's inside Groovy 2.5.6 with time and JSON extensions.
An Android release will follow in a few days.

Thanks everybody for bug reports and patience.


Top
 Profile Send private message 
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Maroon Fusion theme created by Oxydo
Software, theme modifications, phpBB modification by Doti 2010, 2015
This website uses session cookies only.